const regex = /(\/this\/(\w+\s?){1,}\/\w+\/(\w+\s?){1,})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/this\\\/(\\w+\\s?){1,}\\\/\\w+\\\/(\\w+\\s?){1,})', 'g')
const str = `/this/is/single/word
/this/is more than/single/word patterns`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}