$re = '/>([^<]*?)</';
$str = '<div contenteditable="true">
hi</br>
This is a multiple line</br>
code
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);