re = /^\s*(([+-]*)(\d+)\s*([a-zA-Z]+)\s*)+$/m
str = '1day
+1day
-1 day
+1day-1month
+1day +1month
+1day +1month
###+1day+1month
+1day###+1month
+1day+1month###
###+1day+1month###
###+1day+1month###'
# Print the match result
str.match(re) do |match|
puts match.to_s
end