using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<!\w)[?!,])|(?:[?!,](?!\w))";
string substitution = @"";
string input = @"?hello !mango! and, ban,ana yum apple!";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}