#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/foo\/([^\/]+)$"
Local $sString = "// Take this string: /foo/bar" & @CRLF & _
"// which should be applied to: /foo/?" & @CRLF & _
"// where the question mark means required parameter." & @CRLF & _
"" & @CRLF & _
"So the following should be correct:" & @CRLF & _
"/foo/bar" & @CRLF & _
"" & @CRLF & _
"and the following should be wrong:" & @CRLF & _
"/foo" & @CRLF & _
"/foo/" & @CRLF & _
"/foo/bar/abc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")