use strict;
my $str = '// Take this string: /foo/bar
// which should be applied to: /foo/?
// where the question mark means required parameter.
So the following should be correct:
/foo/bar
and the following should be wrong:
/foo
/foo/
/foo/bar/abc';
my $regex = qr/^\/foo\/([^\/]+)$/mp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}