re = /^\/foo\/([^\/]+)$/m
str = '// Take this string: /foo/bar
// which should be applied to: /foo/?
// where the question mark means required parameter.
So the following should be correct:
/foo/bar
and the following should be wrong:
/foo
/foo/
/foo/bar/abc'
# Print the match result
str.match(re) do |match|
puts match.to_s
end