// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\/foo\/([^\/]+)$").unwrap();
let string = "// Take this string: /foo/bar
// which should be applied to: /foo/?
// where the question mark means required parameter.
So the following should be correct:
/foo/bar
and the following should be wrong:
/foo
/foo/
/foo/bar/abc";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}