package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\+?\d+ ?)?(\(\d{1,}\) ?)?([\d\- ]+)*\d$`)
var str = `+27824908354
+27 82 490 8354
+27(82)4908354
+27(82)490 8354
+27(82)490-8354
+27(82)490-- 8354
+27(82)490-8354
0824908354
(082)4908354`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}