import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\+?\\d+ ?)?(\\(\\d{1,}\\) ?)?([\\d\\- ]+)*\\d$";
final String string = "+27824908354\n"
+ "+27 82 490 8354\n"
+ "+27(82)4908354\n"
+ "+27(82)490 8354\n"
+ "+27(82)490-8354\n"
+ "+27(82)490-- 8354\n"
+ "+27(82)490-8354\n"
+ "0824908354\n"
+ "(082)4908354";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}