const regex = /^(\+?\d+ ?)?(\(\d{1,}\) ?)?([\d\- ]+)*\d$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+?\\d+ ?)?(\\(\\d{1,}\\) ?)?([\\d\\- ]+)*\\d$', 'mg')
const str = `+27824908354
+27 82 490 8354
+27(82)4908354
+27(82)490 8354
+27(82)490-8354
+27(82)490-- 8354
+27(82)490-8354
0824908354
(082)4908354`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}