use strict;
my $str = '+27824908354
+27 82 490 8354
+27(82)4908354
+27(82)490 8354
+27(82)490-8354
+27(82)490-- 8354
+27(82)490-8354
0824908354
(082)4908354';
my $regex = qr/^(\+?\d+ ?)?(\(\d{1,}\) ?)?([\d\- ]+)*\d$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}