$re = '/^(\+?\d+ ?)?(\(\d{1,}\) ?)?([\d\- ]+)*\d$/m';
$str = '+27824908354
+27 82 490 8354
+27(82)4908354
+27(82)490 8354
+27(82)490-8354
+27(82)490-- 8354
+27(82)490-8354
0824908354
(082)4908354';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);