Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(\+?\d+ ?)?(\(\d{1,}\) ?)?([\d\- ]+)*\d$
/
mg
Input 1
1
New
+27824908354 +27 82 490 8354 +27(82)4908354 +27(82)490 8354 +27(82)490-8354 +27(82)490-- 8354 +27(82)490-8354 0824908354 (082)4908354