import Foundation
let pattern = #"^(\+?\d+ ?)?(\(\d{1,}\) ?)?([\d\- ]+)*\d$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+27824908354
+27 82 490 8354
+27(82)4908354
+27(82)490 8354
+27(82)490-8354
+27(82)490-- 8354
+27(82)490-8354
0824908354
(082)4908354
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)