$re = '/\b($word)\b/i';
$str = 'ad.somedomain.tld
dad.somedomain.tld
ad.somedomain.tld';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);