package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#([^#]+)#[^#]`)
var str = `#test1 with
multiline headline#
##test2##
###test3###`
var substitution = "<h1>\1</h1>"
fmt.Println(re.ReplaceAllString(str, substitution))
}