// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"#([^#]+)#[^#]").unwrap();
let string = "#test1 with
multiline headline#
##test2##
###test3###";
let substitution = "<h1>\\1</h1>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}