const regex = /(https?:\/\/)?(w{3}\.)?(\w+\.\w{2,3}\.\w{2}?)?(\w+-)?(:?%?\w{2,}\/?\.\w{2,3})?(\/\w+)?(\/[\d\w].+\s$)?(:\d+)?/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/)?(w{3}\\.)?(\\w+\\.\\w{2,3}\\.\\w{2}?)?(\\w+-)?(:?%?\\w{2,}\\\/?\\.\\w{2,3})?(\\\/\\w+)?(\\\/[\\d\\w].+\\s$)?(:\\d+)?', 'gi')
const str = `
https://www.google.co.in/webhp?sourceid=chrome-instant&ion=1&espv=2&ie=UTF-8#q=trie+data+structure+tutorial+%7C+explanation
http://vnc.example.com:5800
gskinner.com/products/spl
gskinner.com
adobe.com/go/flex
google.in
http://boswebsvr009:8090/confluence/display/DEV/Training+for+2015+batch+junior+engineers`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}