package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\?|\&)(?<key>[\w]+)(?:\=|\&?)(?<value>[\w+,.-]*)`)
var str = `css?v=1.0&display=screen`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}