import Foundation
let pattern = #"<img.*?src="(.*?)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<img size="6995" id="img570172" tabindex="0" data-outlook-trace="F:1|T:1" src="data:image/jpeg;base64,iVBORw0KGgoAAAANSUhEUgAAAQMAAADCCAMAAAB6zFdcAAACQFBMVEX///9NTU///v9CQkTzcCD/6wBKSkxFRUeEKZBAQEL/7gD+6AD///2HKJD/5QD/8QBJL5J2K5C1tbZ/KpFhLZFYLpBoLJCrKlE7Oz0Ae77r6+z6pxmsrK3+4QD/2QD/0QCoKVLi4uOdnZ4AfrukK1b9tRXzaQAAh7H"> <img size="6995" id="img570172" tabindex="0" data-outlook-trace="F:1|T:1" src="data:image/jpeg;base64,11111iVBORw0KGgoAAAANSUhEUgAAAQMAAADCCAMAAAB6zFdcAAACQFBMVEX///9NTU///v9CQkTzcCD/6wBKSkxFRUeEKZBAQEL/7gD+6AD///2HKJD/5QD/8QBJL5J2K5C1tbZ/KpFhLZFYLpBoLJCrKlE7Oz0Ae77r6+z6pxmsrK3+4QD/2QD/0QCoKVLi4uOdnZ4AfrukK1b9tRXzaQAAh7H"> <img size="6995" id="img570172" tabindex="0" data-outlook-trace="F:1|T:1" src="data:image/jpeg;base64,22222iVBORw0KGgoAAAANSUhEUgAAAQMAAADCCAMAAAB6zFdcAAACQFBMVEX///9NTU///v9CQkTzcCD/6wBKSkxFRUeEKZBAQEL/7gD+6AD///2HKJD/5QD/8QBJL5J2K5C1tbZ/KpFhLZFYLpBoLJCrKlE7Oz0Ae77r6+z6pxmsrK3+4QD/2QD/0QCoKVLi4uOdnZ4AfrukK1b9tRXzaQAAh7H">"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)