import re
regex = re.compile(r"(?<year>\d{4})-(?<month>[01][0-9])-(?<day>[0123][0-9])", flags=re.MULTILINE)
test_str = ("2018-10-18\n"
"2018-1-1\n"
"2018-12-31\n"
"2018-01-01\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")