re = /\"[^\"]*\"|[^,]+/m
str = 'sunil,"foo, bar","abc,xyz",anil tiwari,"akhilesh,sun", "first,second,third"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end