using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[ACE]_.{2}:A";
string input = @"C_16:A";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}