package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[ACE]_.{2}:A`)
var str = `C_16:A`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}