$re = '/(?<===)(.*?)(?=&)/s';
$str = 'product_type_l1==costumes&+product_type_l2==1950s&+product_type_l3==adult&+product_type_l4==no
filter&+product_type_l5==female&+id=fun2502bl-m';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);