# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^.*?)( )/\1#\2/gm;t' <<< "This is a sentence
Another sentence shall follow up
And yet a third sentence
The goal of these sentences is to show
first spaces that pop up in different line positions
then we'll use regular expressions to
select that first space and then replace that space with
first your insert character and then that space.
This one starts with a space just to cover that
useage scenario
"