#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^.*?)( )"
Local $sString = "This is a sentence" & @CRLF & _
"Another sentence shall follow up" & @CRLF & _
"And yet a third sentence" & @CRLF & _
"" & @CRLF & _
"The goal of these sentences is to show " & @CRLF & _
"first spaces that pop up in different line positions" & @CRLF & _
"then we'll use regular expressions to " & @CRLF & _
"select that first space and then replace that space with " & @CRLF & _
"first your insert character and then that space. " & @CRLF & _
" This one starts with a space just to cover that" & @CRLF & _
" useage scenario" & @CRLF & _
""
Local $sSubst = "\1#\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)