using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^.*?)( )";
string substitution = @"\1#\2";
string input = @"This is a sentence
Another sentence shall follow up
And yet a third sentence
The goal of these sentences is to show
first spaces that pop up in different line positions
then we'll use regular expressions to
select that first space and then replace that space with
first your insert character and then that space.
This one starts with a space just to cover that
useage scenario
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}