import re
regex = re.compile(r"(^.*?)( )", flags=re.MULTILINE)
test_str = ("This is a sentence\n"
"Another sentence shall follow up\n"
"And yet a third sentence\n\n"
"The goal of these sentences is to show \n"
"first spaces that pop up in different line positions\n"
"then we'll use regular expressions to \n"
"select that first space and then replace that space with \n"
"first your insert character and then that space. \n"
" This one starts with a space just to cover that\n"
" useage scenario\n")
subst = "\\1#\\2"
result = regex.sub(subst, test_str)
if result:
print(result)