package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*(?:(?:\B[-'&]+|[-'&]+\B|[^-'&[:^punct:]]+)\s*)+`)
var str = `Good luck!!!!SPRINT I like good deals. I can't lie brand-new stuff---- excites me got& & & & & to say yo, At&t why? a* dash-- apostrophe's''' I can do all-day. But preventing%%%%concatenating is a new**$ballgame but----why--- not?`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}