# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\t\p{Zs}]+/,/g;t' <<< "ABCD A M@L 79
BGDA F D@L 89"