use strict;
my $str = 'ABCD A M@L 79
BGDA F D@L 89';
my $regex = qr/[\t\p{Zs}]+/p;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";