// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\t\p{Zs}]+").unwrap();
let string = "ABCD A M@L 79
BGDA F D@L 89";
let substitution = ",";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}