import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*pos_start=(\\d+).*end_position=(\\d+).*log_type=(\\d+).*length=(\\d+).*block_id=(\\d+).*block_position=(\\d+).*";
final String string = "<log pos_start=\"40652288\" end_position=\"40689664\" log_type=\"1\" length=\"37376\" block_id=\"4024\" block_position=\"18\"/>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}