import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\{\\n\\s*)(?:[^\\}\\{]*)(\\n\\s*\\{)";
final String string = "\n\n"
+ "{\n\n"
+ "\"origin\" \"887 -100 128\"\n\n"
+ "\"texture\" \"{gargstomp\"\n\n"
+ "\"classname\" \"infodecal\"\n\n"
+ "}\n\n"
+ " \n";
final String subst = "\\1 \\2";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}