using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b
(?!\p{Lu}+\b) # CaMeL can't be an ALLCAPS (remove to allow)
(?=\p{L}*\p{Ll}) # CaMeL word should have at least 1 lowercase letter
(?=\p{L}*\p{Lu}) # CaMeL word should have at least 1 uppercase letter
(?!\p{Lu}\p{Ll}*\b) # CaMeL word can't be `Xxxx` or `X`
\p{L}+ # CaMeL word should contain at least 1 letter
\b";
string input = @"CaMeL
cAMEL
caMEL
camEL
cameL
CameL
CAmel
CAMel
CAMeL
cAmEL";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}