import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\n"
+ " (?!\\p{Lu}+\\b) # CaMeL can't be an ALLCAPS (remove to allow)\n"
+ " (?=\\p{L}*\\p{Ll}) # CaMeL word should have at least 1 lowercase letter\n"
+ " (?=\\p{L}*\\p{Lu}) # CaMeL word should have at least 1 uppercase letter\n"
+ " (?!\\p{Lu}\\p{Ll}*\\b) # CaMeL word can't be `Xxxx` or `X`\n"
+ " \\p{L}+ # CaMeL word should contain at least 1 letter \n"
+ "\\b";
final String string = "CaMeL\n"
+ "cAMEL\n"
+ "caMEL\n"
+ "camEL\n"
+ "cameL\n"
+ "CameL\n"
+ "CAmel\n"
+ "CAMel\n"
+ "CAMeL\n"
+ "cAmEL";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}