const regex = /\b
(?!\p{Lu}+\b) # CaMeL can't be an ALLCAPS (remove to allow)
(?=\p{L}*\p{Ll}) # CaMeL word should have at least 1 lowercase letter
(?=\p{L}*\p{Lu}) # CaMeL word should have at least 1 uppercase letter
(?!\p{Lu}\p{Ll}*\b) # CaMeL word can't be `Xxxx` or `X`
\p{L}+ # CaMeL word should contain at least 1 letter
\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b
(?!\\p{Lu}+\\b) # CaMeL can\'t be an ALLCAPS (remove to allow)
(?=\\p{L}*\\p{Ll}) # CaMeL word should have at least 1 lowercase letter
(?=\\p{L}*\\p{Lu}) # CaMeL word should have at least 1 uppercase letter
(?!\\p{Lu}\\p{Ll}*\\b) # CaMeL word can\'t be `Xxxx` or `X`
\\p{L}+ # CaMeL word should contain at least 1 letter
\\b', 'g')
const str = `CaMeL
cAMEL
caMEL
camEL
cameL
CameL
CAmel
CAMel
CAMeL
cAmEL`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}