const regex = /{{var:([^}=]+)(?:=([^}]*))?}}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{{var:([^}=]+)(?:=([^}]*))?}}', 'gm')
const str = `This is {{var:my_dog}} and it is {{var:my_awesome}}.
But this is {{var:not.existing=}} because it has a default {{var:not.existing=value}}`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);