re = /(?<!(def\s))(?<=^|\s)[a-zA-Z_][\w_]*(?=\()/m
str = 'def anyfunc(vars...):
pass
_other_func2(vars...)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end