package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\.?(?:(?:\d{1,3}[,. ])*\d{1,3}(?:\.\d{2})?|\d+\.\d+|\d+)\.?$`)
var str = `.2.4.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}