$re = '/[0-9.]+(?=_)/';
$str = 'com.abc.def.abcdef-1.6.0_newversion-2.3.7-debug';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);