using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"('(?=\S)[^']*\S')|:";
string substitution = @"$1@";
string input = @"select ':' id, :DATA_INI, ':DATA_INI', titulo, date_format(data_criacao,'%d/%m/%Y %H:%i') str_data_criacao
from v$sugestoes
where data_criacao between :DATA_INI AND :DATA_FIM
order by data_criacao";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}