$re = '/(\'(?=\S)[^\']*\S\')|:/';
$str = 'select \':\' id, :DATA_INI, \':DATA_INI\', titulo, date_format(data_criacao,\'%d/%m/%Y %H:%i\') str_data_criacao
from v$sugestoes
where data_criacao between :DATA_INI AND :DATA_FIM
order by data_criacao';
$subst = "$1@";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;