// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([^>]+):").unwrap();
let string = "<IMG SRC=\"/include/images/moredetails.png\" WIDTH=\"8\" HEIGHT=\"7\" ONMOUSEOVER=\"return createPopup('<b>[scan_name@user:home]:</b> <!-- #EscapedName# --><br><b>[organization@user:home]:</b><br><!-- #EscapedOrganizationPath# --><br><b>[total@user:home]:</b> <!-- #EscapedTotal# --><br><b>[high@user:home]:</b> <!-- #EscapedHigh# --><br><b>[medium@user:home]:</b> <!-- #EscapedMedium# --><br><b>[low@user:home]:</b> <!-- #EscapedLow# --><br><b>[date_last_scanned@user:home]:</b> <!-- #EscapedDate# -->');\" ONMOUSEOUT=\"return nd(1000);\"><!-- #Name# --></TD>
<IMG SRC=\"/include/images/moredetails.png\" WIDTH=\"8\" HEIGHT=\"7\" ONMOUSEOVER=\"return createPopup('<b>[scan_name@user:home]:</b> <!-- #EscapedName# --><br><b>ì¡°ì§/부서 경로:</b><br><!-- #EscapedOrganizationPath# --><br><b>[total@user:home]:</b> <!-- #EscapedTotal# --><br><b>[high@user:home]:</b> <!-- #EscapedHigh# --><br><b>[medium@user:home]:</b> <!-- #EscapedMedium# --><br><b>[low@user:home]:</b> <!-- #EscapedLow# --><br><b>[date_last_scanned@user:home]:</b> <!-- #EscapedDate# -->');\" ONMOUSEOUT=\"return nd(1000);\"><!-- #Name# --></TD>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}