const regex = /(http:|https:|)\/\/(player.|www.)?(vimeo\.com|youtu(be\.com|\.be|be\.googleapis\.com))\/(video\/|embed\/|watch\?v=|v\/)?([A-Za-z0-9._%-]*)(\&\S+)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http:|https:|)\\\/\\\/(player.|www.)?(vimeo\\.com|youtu(be\\.com|\\.be|be\\.googleapis\\.com))\\\/(video\\\/|embed\\\/|watch\\?v=|v\\\/)?([A-Za-z0-9._%-]*)(\\&\\S+)?', 'g')
const str = `https://youtu.be/wOgIkxAfJsk
http://player.vimeo.com/video/25451551
http://vimeo.com/25451551
https://youtube.googleapis.com/v/My2FRPA3Gf8
http://youtu.be/My2FRPA3Gf8
http://www.youtube.com/watch?v=My2FRPA3Gf8
//player.vimeo.com/video/25451551`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}