$re = '/(http:|https:|)\/\/(player.|www.)?(vimeo\.com|youtu(be\.com|\.be|be\.googleapis\.com))\/(video\/|embed\/|watch\?v=|v\/)?([A-Za-z0-9._%-]*)(\&\S+)?/';
$str = 'https://youtu.be/wOgIkxAfJsk
http://player.vimeo.com/video/25451551
http://vimeo.com/25451551
https://youtube.googleapis.com/v/My2FRPA3Gf8
http://youtu.be/My2FRPA3Gf8
http://www.youtube.com/watch?v=My2FRPA3Gf8
//player.vimeo.com/video/25451551';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);