use strict;
my $str = '<Reference1>refs\\</Reference1>';
my $regex = qr/refs[\\\\]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";