$re = '/\b(?:typedef struct|typedef|struct)\b
[^;{}]+
(?: ( \{ (?: [^{}]++ | (?1) )+ \} ) [^;]* )?
;/x';
$str = '
typedef struct SS__DD WEFGEGWEG;
struct SS__DD WEFGEGWEG;
typedef struct SS__DD {
DFBFFN *trait_method;
union {
HRTRTH *cRTNe;
RTHR 56J56;
} *SEGWEG;
} WEFGEGWEG;
typedef struct SS__DD {
DFBFFN *trait_method;
union {
HRTRTH *cRTNe;
RTHR 56J56;
} *SEGWEG;
} WEFGEGWEG, WEFGE4Y45Y;
typedef struct SS__DD {
DFBFFN *trait_method;
union {
HRTRTH *cRTNe;
RTHR 56J56;
} *SEGWEG;
};
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);